CELTA Students at computers

Online CELTA: Technical Requirements



Equipment

The following equipment is required to run the Online Cambridge CELTA Course:
  • computer monitor – we recommend a screen resolution of 1024x768 pixels
  • internet connection – we recommend you use a reliable broadband-speed connection to be able to handle progressively downloaded videos and virtual classroom sessions with audio
  • a good quality USB headset with headphones and microphone built in

Minimum Hardware Requirements

We recommend the following minimum hardware specifications to run the course:
  • Windows XP Home and Professional 800MHz Processor with 256MB RAM
  • All versions of Windows Vista 1GHz processor with 1GB RAM
  • All versions of Windows 7 1GHz processor with 1GB RAM
  • MAC OSX 10.3 or higher 1GHz processor with 1GB RAM
You may be able to run the course on machines with lower specification hardware although you may experience performance issues with media-rich activities.

Please note: The course will NOT run on an iPad.

The download speed of the videos included on the course will depend both on your hardware configuration and the speed of your broadband connection. If the streaming stops after a short while then it is advisable to wait until the download is complete.

Software Requirements

Web Browser

You will need an up-to-date web browser to run the course. We recommend the following browsers for the Online Cambridge CELTA Course:
  • Firefox 3 or higher
  • Safari
We suggest that you avoid the use of Internet Explorer if possible. Internet Explorer 8 will work fine, but please do not use IE9 at this stage as some features of the course do not perform as well as they do in other browsers.

Note: The course can also be run in other browsers. However, some features of the interface may exhibit bugs in non-recommended browsers.

Downloads of browsers:

Firefox – http://www.mozilla.com/en-US/firefox/new/
Safari – http://www.apple.com/safari/download/

Microsoft Word

You will need Microsoft Word for the course (either PC or Mac version). Mac users who do not have a copy of Word installed may wish to use the open source (free) Libre office: http://www.libreoffice.org although not all course features will work as well as Microsoft Word.

Required Plugins

Your browser will require the following plugins to be installed and enabled: To check if you have the correct plugins installed, please click on the links above.

If you are not using your own computer please note that you may need to contact your institution's I.T. administrator to be able to change your browser settings or install plugins.